ubuntu 16.04 安装sublime3

1、安装Sublime Text 3

首先添加sublime text 3的仓库:

sudo add-apt-repository ppa:webupd8team/sublime-text-3

根据提示按ENTER 继续,建立信任数据库

 

更新软件库

sudo apt update

 

安装Sublime Text 3

sudo apt install sublime-text-installer

等待软件安装成功……

 

 

2、安装Packeage Control

输入命令subl打开Sublime Text 3

按快捷键ctrl + `(ESC下面的那个键),在弹出的控制台中输入如下代码按回车:

import urllib.request,os,hashlib; h = ‘2915d1851351e5ee549c20394736b442‘ + ‘8bc59f460fa1548d1514676163dafc88‘; pf = ‘Package Control.sublime-package‘; ipp = sublime.installed_packages_path(); urllib.request.install_opener( urllib.request.build_opener( urllib.request.ProxyHandler()) ); by = urllib.request.urlopen( ‘http://packagecontrol.io/‘ + pf.replace(‘ ‘, ‘%20‘)).read(); dh = hashlib.sha256(by).hexdigest(); print(‘Error validating download (got %s instead of %s), please try manual install‘ % (dh, h)) if dh != h else open(os.path.join( ipp, pf), ‘wb‘ ).write(by)  

重启软件后可以在Preference菜单下找到Package Control命令,单击运行Packeage Control,搜索Install Package并进入该选项,此时即可为Sublime Text 3安装所需插件

 

3、安装SulimeClang 插件

   SublimeClang 是Sublime Text中唯一的C/C++自动补全插件,功能强大,自带语法检查功能,不过最近作者已经停止更新了,目前只能在Sublime Text 2的Package Control中可以找到并自动安装,在SublimeText 3中只能手动通过源码安装,其代码线在https://github.com/quarnster/SublimeClang中。具体安装步骤如下:

安装相关软件
    sudo apt-get install cmake build-essential clang git
    cd ~/.config/sublime-text-3/Packages
    git clone –recursive https://github.com/quarnster/SublimeClang SublimeClang
    cd SublimeClang
    cp /usr/lib/x86_64-linux-gnu/libclang-3.4.so.1 internals/libclang.so

 

重启软件,按ctrl + `打开控制台,查看是否有错误信息输出,若没有则代表安装成功

 

配置插件

按ctrl + shift + p 快捷键,在弹出的输入框中输入sublimeclang settings,选择带User的那一行,在打开的文件中输入如下信息:

{
    “show_output_panel”: false,
    “dont_prepend_clang_includes”: true,
    “inhibit_sublime_completions”: false,

    “options”:
    [
        “-std=gnu++11”,
        “-isystem”, “/usr/include”,
        “-isystem”, “/usr/include/c++/*”,
        “-isystem”, “/usr/include/c++/5.3.1”,
        “-isystem”, “/usr/include/c++/5.3.1/*”,
        “-isystem”, “/usr/include/boost”,
        “-isystem”, “/usr/include/boost/**”,
        “-isystem”, “/usr/lib/gcc/x86_64-linux-gnu/5.3.1/include”,
        “-isystem”, “/usr/lib/gcc/x86_64-linux-gnu/5.3.1/include/*”
    ]
}

将以上信息中的gcc版本号替换成自己系统中的版本号

 

完成这一步就可以愉快地使用Sublime Text 3

Refer: 点滴记录——Ubuntu 14.04中安装Sublime Text 3并使用SublimeClang插件

ubuntu 16.04 安装sublime3

原文地址:http://www.cnblogs.com/shiddong/p/6106504.html

为您推荐

发表评论

电子邮件地址不会被公开。 必填项已用*标注